OSPF: LAB: REDISTRIBUTION AMONG DIFFERENT PROCESSES 1


 

****************

REDISTRIBUTION AMONG DIFFERENT PROCESS

 

SCENARIO:

This is the most common scenario in any of the network. we have Dual connectivity to the LAN network 33.33.33.0/24

 through R1 & R2. Process ID 1 & 2 are running.

 

PLAN 1:  

we have to resdistribute between two processess, without doing any modification with Parameters. Check out the result

PLAN 2:

Then, do MODIFICATION: Play with the AD value and check out the result

*********************

PREREQUISITES

If route is learned from:

Multiple protocols —>> AD Values are compared. Example: Static preffered over OSPF

OSPF network —->>Single Process 

Prefference Rule: Intra Area> Inter Area> External E1 > External E2

or,

LSA-1 or LSA-2  >  LSA-3 > LSA-5 or LSA-7

OSPF network  —–>> Multiple Process (Above rule is not applicable)

Multiple processes do not exchange routes by itself, until and unless configured to do so

*********************

 

 

OSPF REDISTRIBUTION AMONG PROCESSES

 


PLAN 1

CONFIGURATION  FOR RUNNING OSPF

R1:

R1#sh ip int br
Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0/0            192.168.1.1     YES NVRAM  up                    up
FastEthernet0/1            172.16.1.1      YES NVRAM  up                    up
FastEthernet1/0            unassigned      YES NVRAM  administratively down down

R1#sh run | be ospf
router ospf 2
log-adjacency-changes
network 172.16.1.1 0.0.0.0 area 0
!
router ospf 1
log-adjacency-changes
redistribute ospf 2 subnets
network 192.168.1.1 0.0.0.0 area 0

R2:

R2#sh ip int br
Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0/0            192.168.1.2     YES NVRAM  up                    up
FastEthernet0/1            172.16.1.2      YES NVRAM  up                    up

R2#sh run | be ospf
router ospf 1
log-adjacency-changes
redistribute ospf 2 subnets
network 192.168.1.2 0.0.0.0 area 0
!
router ospf 2
log-adjacency-changes
redistribute ospf 1 subnets
network 172.16.1.2 0.0.0.0 area 0

R3

R3#sh ip int br
Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0/0            192.168.1.3     YES NVRAM  up                    up
FastEthernet0/1            unassigned      YES NVRAM  administratively down down
FastEthernet1/0            unassigned      YES NVRAM  administratively down down
Loopback0                  33.33.33.1      YES NVRAM  up                    up

R3#sh run | be ospf
router ospf 1
log-adjacency-changes
network 33.33.33.1 0.0.0.0 area 0
network 192.168.1.3 0.0.0.0 area 0

R4

R4#sh ip int br
Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0/0            172.16.1.3      YES NVRAM  up                    up
FastEthernet0/1            unassigned      YES NVRAM  administratively down down

R4#sh run | be ospf
router ospf 2
log-adjacency-changes
network 172.16.1.3 0.0.0.0 area 0

Configuration Details

Here, OSPF is enabled on R1, R2, R3 & R4

Process ID 1 running in upper Half of the network

Process ID 2 running in the lower half of the network

Redistribution done at R1 & R2 to allow routes exchange between two different processes

/Without Redistribution, there will be no exhange of routes between two different processes/

33.33.33.0/24 is connected to R4 and acting as LAN here, which needs to be accessed

 

Problem

At R1,

33.33.33.0/24  should be learned as OSPF route

But, here 33.33.33.0/24 is learned as E2 route

 

R1#sh ip ro
33.0.0.0/32 is subnetted, 1 subnets

O E2    33.33.33.1 [110/2] via 172.16.1.2, 00:31:30, FastEthernet0/1
172.16.0.0/24 is subnetted, 1 subnets
C       172.16.1.0 is directly connected, FastEthernet0/1
C    192.168.1.0/24 is directly connected, FastEthernet0/0

 

So, From above conclusion is,  33.33.33.0/24 is learned indirectly

33.33.33.0/24  —>  R3  —->   R2  ——>  as E2 route in process ID 2  —>  Learned as E2 route at R1 through Process ID 2

In normal case, Path should be

33.33.33.0/24  —>  R3  —-> Learned as OSPF route at R1 through Process ID  1

 

At R2,

R2#sh ip ro
33.0.0.0/32 is subnetted, 1 subnets

O       33.33.33.1 [110/2] via 192.168.1.3, 00:35:48, FastEthernet0/0
172.16.0.0/24 is subnetted, 1 subnets
C       172.16.1.0 is directly connected, FastEthernet0/1
C    192.168.1.0/24 is directly connected, FastEthernet0/0

 

Conclusion is:

Path is normal, 33.33.33.0/24 learned directly through Process 1

 

 

OVERALL, RESULT IS INDETERMINISTIC

At R1 and R2 both, whatever learned first,  either as Internal or External route, gets installed as route


PLAN 2

https://networkproxy.wordpress.com/2014/03/26/ospf-lab-redistribution-among-different-processes-2/#more-572

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s