BGP: LAB: MULTIHOMING / DUAL HOMED / SINGLE ROUTER 1


SCENARIO

DUAL HOMED CASE

 

40a.gif

 


POINT OF VIEW

In above case, we have two options to make BGP neighborship

First Option: Through Loopback interface

Second Option: Through both Physical interfaces

 

Which is better option and why ?

Hint:

Compare in terms of Router Processing

&

In terms of Load Balancing

&

In terms of Failover

 

Pour in your comments .. !!

 


CONFIGURATION

FIRST OPTION

At Router A

interface Loopback0
ip address 1.1.1.1 255.255.255.0
!

interface Serial2/0
ip address 160.20.20.1 255.255.255.0
no ip route-cache cef
no ip route-cache
serial restart-delay 0
!
interface Serial2/1
ip address 150.10.10.1 255.255.255.0
no ip route-cache cef
no ip route-cache
serial restart-delay 0
!

router eigrp 12
network 1.0.0.0
network 150.10.0.0
network 160.20.0.0
no auto-summary
!
router bgp 11
no synchronization
bgp log-neighbor-changes
neighbor 2.2.2.2 remote-as 10
neighbor 2.2.2.2 ebgp-multihop 255
neighbor 2.2.2.2 update-source Loopback0
no auto-summary

At Router B

interface Loopback0
ip address 2.2.2.2 255.255.255.0
!

interface Serial2/0
ip address 160.20.20.2 255.255.255.0
no ip route-cache cef
no ip route-cache
serial restart-delay 0
!
interface Serial2/1
ip address 150.10.10.2 255.255.255.0
no ip route-cache cef
no ip route-cache
serial restart-delay 0

!

router eigrp 12
network 2.0.0.0
network 150.10.0.0
network 160.20.0.0
no auto-summary
!
router bgp 10
no synchronization
bgp log-neighbor-changes
neighbor 1.1.1.1 remote-as 11
neighbor 1.1.1.1 ebgp-multihop 255
neighbor 1.1.1.1 update-source Loopback0
no auto-summary
!

 

VERIFICATION

1. LOAD BALANCING

RouterA#traceroute 2.2.2.2

Type escape sequence to abort.
Tracing the route to 2.2.2.2

1 160.20.20.2 40 msec
150.10.10.2 40 msec
160.20.20.2 32 msec

2. FAILOVER SCENARIO

RouterA(config)#int s2/0
RouterA(config-if)#shut

 

RouterA#traceroute 2.2.2.2

Type escape sequence to abort.
Tracing the route to 2.2.2.2

1 150.10.10.2 28 msec 44 msec 32 msec

 

POINTS TO BE NOTED

  1. neighbor 1.1.1.1 update-source loopback 0
    !— Use the IP address of the loopback interface for TCP connections.

 

2.neighbor 2.2.2.2 ebgp-multihop

!— You must configure ebgp-multihop whenever the external BGP (eBGP)

!— connections are not on the same network address.

 

3.EIGRP configured to provide reachability from Router A and Router B


 

 

 

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s