BGP: LAB: MULTIHOMING / DUAL HOMED / SINGLE ROUTER 2


REFERENCE  GNS3 LAB

https://drive.google.com/file/d/0B_coLzIg1OZ5bXZqY1k5YktVNUE/edit?usp=sharing

How To Download: Click on above link –>Go to FILE –> Click on Download –> Unzip the GNS3 File

 

SCENARIO

Load Sharing When Dual-Homed to One Internet Service Provider (ISP) Through a Single Local Router

 

 

40b.gif

 

CONFIGURATION

 At RA:

interface Loopback0

ip address 1.1.1.1 255.255.255.0

!

interface Serial0/0

ip address 160.20.20.1 255.255.255.0

serial restart-delay 0

!

interface Serial0/1

ip address 150.10.10.1 255.255.255.0

serial restart-delay 0

!

router bgp 11

no synchronization

bgp log-neighbor-changes

network 1.0.0.0

neighbor 150.10.10.2 remote-as 10

neighbor 160.20.20.2 remote-as 10

maximum-paths 2

no auto-summary

 

At RB:

interface Serial0/0

ip address 160.20.20.2 255.255.255.0

serial restart-delay 0

!

interface Ethernet1/0

ip address 2.2.2.1 255.255.255.0

half-duplex

!

router bgp 10

no synchronization

bgp log-neighbor-changes

network 2.0.0.0

neighbor 160.20.20.1 remote-as 11

auto-summary

!

 

At RC:

interface Serial0/1

ip address 150.10.10.2 255.255.255.0

serial restart-delay 0

!

interface Ethernet1/0

ip address 2.2.2.2 255.255.255.0

half-duplex

!

router bgp 10

no synchronization

bgp log-neighbor-changes

network 2.0.0.0

neighbor 150.10.10.1 remote-as 11

auto-summary

!

 

VERIFICATION

1.  BOTH PATHS INSTALLED FOR A REMOTE NETWORK, 2.0.0.0/8

R1#sh ip ro

1.0.0.0/24 is subnetted, 1 subnets

C       1.1.1.0 is directly connected, Loopback0

B    2.0.0.0/8 [20/0] via 160.20.20.2, 00:09:04

               [20/0] via 150.10.10.2, 00:08:53

160.20.0.0/24 is subnetted, 1 subnets

C       160.20.20.0 is directly connected, Serial0/0

150.10.0.0/24 is subnetted, 1 subnets

C       150.10.10.0 is directly connected, Serial0/1

 

2. BEST PATH SELECTED

R1#sh ip bgp 2.0.0.0

BGP routing table entry for 2.0.0.0/8, version 10

Paths: (2 available, best #1, table Default-IP-Routing-Table)

Multipath: eBGP

Advertised to non peer-group peers:

160.20.20.2

10

150.10.10.2 from 150.10.10.2 (150.10.10.2)

      Origin IGP, metric 0, localpref 100, valid, external, multipath, best

  10

160.20.20.2 from 160.20.20.2 (160.20.20.2)

Origin IGP, metric 0, localpref 100, valid, external, multipath

 

3.  LOAD BALANCING

PROBLEM:

This is not doing the Load Balancing, which it should do ideally

Best Path is chosen, whereas we have already used command: maximum-path 2

So put in your comments  and find out the missing thing .. !!

 

R1#ping 2.2.2.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2.2.2.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/14/44 ms

 

R1#ping 2.2.2.2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2.2.2.2, timeout is 2 seconds:
…..
Success rate is 0 percent (0/5)

 

R1#traceroute 2.2.2.1

Type escape sequence to abort.
Tracing the route to 2.2.2.1

1 160.20.20.2 12 msec * 8 msec

 

R1#traceroute 2.2.2.2

Type escape sequence to abort.
Tracing the route to 2.2.2.2

1 160.20.20.2 32 msec *  64 msec
2  *  *  *
3  *

 

POINTS TO NOTE

  1. What is the default method of Load Balancing in BGP ?

  2. What is the purpose of command: auto summary

 

 

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s