VLAN, TRUNKING, VTP: UNDERSTANDING TOPOLOGY


SH VLAN BRIEF   vs   SH VLAN ID <VLAN NO.>

SH VLAN BRIEF

CONFIGURATION
core_1#sh vlan br
VLAN Name Status Ports
100 Wireless active

COMMENT

There is no port assigned to VLAN 100. So, sh vlan br shows the ports of the switch, which are assigned to VLAN 100.

 

SH VLAN ID < VLAN NO. >

CONFIGURATION
core_1#sh vlan id 100
VLAN Name Status Ports


100 Wireless active Gi7/2

COMMENT

Here, port shown is Gi7/2. It does not mean that port gi7/2 is assigned to VLAN 100. But, it shows that VLAN 100 is allowed on VLAN 100.

 

Below output confirms that Gi 7/2 is not assigned to VLAN 100, whereas Gi7/2 allows traffic for VLAN 100.
core_1#sh running-config int gi7/2
interface GigabitEthernet7/2
description Connection to office switch
no ip address
switchport
switchport trunk encapsulation dot1q
switchport trunk native vlan 2
switchport trunk allowed vlan 1,2,5,61,100,1001-4094
switchport mode trunk

 

How to check Layer 2 & Layer 3 VLAN’s with their associated ports ?

CONFIG

core_1#sh vlan br

VLAN Name Status Ports

1 default active Gi3/7, Gi4/32, Gi5/39, Gi9/18, Gi9/43, Gi11/3, Gi11/18, Gi11/36, Gi11/37, Gi11/48

2 Management active Gi3/26, Gi3/32, Gi6/8

COMMENT

Output shows both Layer 2 & Layer 3 VLAN’s

 

How to check Layer 3 VLAN’s?

CONFIG

core_1#sh run | i interface Vlan

interface Vlan1

interface Vlan2

interface Vlan3

interface Vlan4

COMMENT

Output shows Layer 3 VLAN’s. As to configure Layer 3 VLAN,

we need to put command “interface vlan < vlan number >”.

So, command starting from “ interface Vlan “ are all Layer 3 VLAN’s

 

How to check Trunk ports on a switch,

Encapsulation types used,

Native VLAN for Trunk ports,

Allowed VLAN’s on Trunk ports?

CONFIG

core_1#sh int trunk

Port      Mode  Encapsulation Status     Native vlan

Gi3/34   on          802.1q               trunking     1

Gi3/35   on          802.1q                trunking    1

Port Vlans allowed on trunk

Gi3/34 3-5

Gi3/35 3-5

Port Vlans in spanning tree forwarding state and not pruned

Gi3/34 3-5

Gi3/35 3-5

 

How to check Speed/ Duplex setting of ports & which are the Trunk Ports?

CONFIG

core_1#sh int status

Port Name Status Vlan Duplex Speed Type

Gi3/1 G3/1 Connection to notconnect 61 auto auto 10/100/1000BaseT

Gi3/2 Connection for TOR connected 3 a-full a-1000 10/100/1000BaseT

Gi3/3 Gi3/3 Connection f connected trunk full 1000 10/100/1000BaseT

COMMENT

Speed & Duplex column is given for every port. G3/3 is Trunk port here.

 

How to check VTP details ?

CONFIG

core_1#sh vtp status

VTP Version : 2

Configuration Revision : 54

Maximum VLANs supported locally : 1005

Number of existing VLANs : 38

VTP Operating Mode : Server

VTP Domain Name : Fuse_DC

VTP Pruning Mode : Disabled

VTP V2 Mode : Disabled

VTP Traps Generation : Enabled

MD5 digest : 0x08 0x2A 0x02 0x30 0x6E 0x37 0x2F 0x23

Configuration last modified by 127.0.0.81 at 3-10-09 19:55:56

Local updater ID is 10.146.2.1 on interface Vl2 (lowest numbered VLAN interface found)

FEW SWITCH PORT EXAMPLE CONFIGURATION

Example: Port connected to server

interface Vlan3

description Server data VLAN

ip address 10.146.3.1 255.255.255.0

ip helper-address 10.144.5.144

 

Example: Port connected to Video conferencing

SW1#sh running-config int g1/0/35

interface GigabitEthernet1/0/35

description G1/0/35 VC#1 10.151.254.52/28

switchport access vlan 90

switchport mode access

priority-queue out

mls qos trust dscp

spanning-tree portfast

spanning-tree bpduguard enable

 

Example: Port connected to MPLS

SW1#sh running-config int g1/0/1

interface GigabitEthernet1/0/1

description Tempe_Rtr1 G0/0

switchport access vlan 10

priority-queue out

mls qos trust dscp

end

Advertisements

One comment

  1. Hi Sumit, This is Shubham here,

    I would like to say for you, that you are doing very good job for all the networking geek,

    I would like to give you one advice is that in Real World Scenario Section, you should give Diagram and ask for troubleshooting, it will help to all for improving troubleshooting skills,

    Company Interviews: Scenario based question should be included,

    one thing is I am not getting any response in your group on fb after posting my queries, specially after you set policy in group.

    All the best!!!!

    Like

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s