STATIC TO OSPF REDISTRIBUTION: 4 CASE STUDIES


TOPICS

GENERAL SCENARIO & CONFIGURATION

CASE 1: OUTPUT & POINTS TO NOTE

CASE 2: OUTPUT & POINTS TO NOTE

CASE 3: OUTPUT & POINTS TO NOTE

CASE4: OUTPUT & POINTS TO NOTE

REFERENCE LINK


 

GENERAL SCENARIO & CONFIGURATION

 

DIAGRAM

 

SCENARIO

Two static routes added pointing to E0 on RTC

16.16.16.0 255.255.255.0 (/24) and 128.213.0.0 255.255.0.0 (/16)

 

CONFIGURATION

RTC CONFIGURATION

interface Ethernet0

ip address 203.250.14.2 255.255.255.0

 

interface Serial1

ip address 203.250.15.1 255.255.255.252

 

router ospf 10

CASE 1, CASE 2, CASE 3         <<—— SEE BELOW FOR DIFFERENT CASES

network 203.250.15.0 0.0.0.255 area 2

network 203.250.14.0 0.0.0.255 area 0

/ OSPF configuration /

 

ip route 16.16.16.0 255.255.255.0 Ethernet0

ip route 128.213.0.0 255.255.0.0 Ethernet0

/ Static Routes /

 

RTE CONFIGURATION

interface Serial0

ip address 203.250.15.2 255.255.255.252

 

router ospf 10

network 203.250.15.0 0.0.0.255 area 2


 

CASE 1:

USING COMMAND: redistribute static

OUTPUT

RTE# show ip route

Codes: C – connected, S – static, I – IGRP, R – RIP, M – mobile, B – BGP

D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area

E1 – OSPF external type 1, E2 – OSPF external type 2, E – EGP

i – IS-IS, L1 – IS-IS level-1, L2 – IS-IS level-2, * – candidate default

 

Gateway of last resort is not set

203.250.15.0 255.255.255.252 is subnetted, 1 subnets

C       203.250.15.0 is directly connected, Serial0

O IA 203.250.14.0 [110/74] via 203.250.15.1, 00:02:31, Serial0

O E2 128.213.0.0 [110/20] via 203.250.15.1, 00:02:32, Serial0

 

POINTS TO NOTE

Here, Route type is E2.

If the subnet keyword is not used, only routes that are not subnetted will be redistributed.

Only external route that has appeared is 128.213.0.0 only, because we did not use the subnet keyword.

Here, 16.16.16.0 is a class A route that is subnetted. So, it is not getting redistributed.

Here, in E2 route, /20 represents the default value of cost


 

CASE 2:

USING COMMAND: redistribute static metric 50 subnets

OUTPUT

RTE#show ip route

Codes: C – connected, S – static, I – IGRP, R – RIP, M

  • mobile, B – BGP

D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area

E1 – OSPF external type 1, E2 – OSPF external type 2, E – EGP

i – IS-IS, L1 – IS-IS level-1, L2 – IS-IS level-2, * – candidate default

 

Gateway of last resort is not set

16.0.0.0 255.255.255.0 is subnetted, 1 subnets

O E2   16.16.16.0 [110/50] via 203.250.15.1, 00:00:02, Serial0

203.250.15.0 255.255.255.252 is subnetted, 1 subnets

C       203.250.15.0 is directly connected, Serial0

O IA 203.250.14.0 [110/74] via 203.250.15.1, 00:00:02, Serial0

O E2 128.213.0.0 [110/50] via 203.250.15.1, 00:00:02, Serial0

 

POINTS TO NOTE

Here, Route type is E2.

16.16.16.0 Has shown up now, as keyword subnet has been used in configuration.

Cost to external routes is 50, only external cost has been shown, as route type is E2.


 

CASE 3:

USING COMMAND: redistribute static metric 50 metric-type 1 subnets

OUTPUT

RTE#show ip route

Gateway of last resort is not set

16.0.0.0 255.255.255.0 is subnetted, 1 subnets

O E1   16.16.16.0 [110/114] via 203.250.15.1, 00:04:20, Serial0

203.250.15.0 255.255.255.252 is subnetted, 1 subnets

C       203.250.15.0 is directly connected, Serial0

O IA 203.250.14.0 [110/74] via 203.250.15.1, 00:09:41, Serial0

O E1 128.213.0.0 [110/114] via 203.250.15.1, 00:04:21, Serial0

 

POINTS TO NOTE

Here, Route type is changed to E1

Total cost is 64+50= internal + external = 114


 

CASE 4

USING COMMAND: redistribute static metric 50 metric-type 1 subnets route-map STOPUPDATE 

CONFIGURATION

RTC# interface Ethernet0

ip address 203.250.14.2 255.255.255.0

interface Serial1

ip address 203.250.15.1 255.255.255.252

 

router ospf 10 redistribute static metric 50 metric-type 1 subnets route-map STOPUPDATE

network 203.250.15.0 0.0.0.255 area 2

network 203.250.14.0 0.0.0.255 area 0

 

ip route 16.16.16.0 255.255.255.0 Ethernet0

ip route 128.213.0.0 255.255.0.0 Ethernet0

access-list 1 permit 128.213.0.0 0.0.255.255

 

route-map STOPUPDATE permit 10

match ip address 1

 

OUTPUT

Gateway of last resort is not set

203.250.15.0 255.255.255.252 is subnetted, 1 subnets

C       203.250.15.0 is directly connected, Serial0

O IA 203.250.14.0 [110/74] via 203.250.15.1, 00:00:04, Serial0

O E1 128.213.0.0 [110/114] via 203.250.15.1, 00:00:05, Serial0

 

POINTS TO NOTE

The route map above will only permit 128.213.0.0 to be redistributed into OSPF and will deny the rest.

This is why 16.16.16.0 does not show up in RTE’s routing table anymore.


 

REFERENCE LINK

OSPF DESIGN GUIDE

http://www.cisco.com/c/en/us/support/docs/ip/open-shortest-path-first-ospf/7039-1.html#t33


 

 

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s